macOS users need to update to Safari 15.6.1 to close a security hole

Safari now has more than 1 billion users.
macOS Big Sur or macOS Catalina users really need Safari 15.6.1.
Photo: Apple

A recent macOS Monterey update deals with a nasty security problem in WebKit. But Apple is aware many users don’t upgrade to the latest operating system versions so it also released Safari 15.6.1 allowing anyone using older macOS versions can also not have to worry about the issue.

The browser update is free and available now.

Safari 15.6.1 is available for macOS

A bug in Apple’s WebKit rendering engine discovered by a security researcher allows a malicious web page to execute code without users’ permission. Even worse, “Apple is aware of a report that this issue may have been actively exploited,” warns the Mac-maker.

As noted, the problem is fixed in the recent macOS Monterey 12.5.1 update. And now it can also be taken care of for computers still running macOS Big Sur or macOS Catalina with a web browser update.

All that’s necessary is to install Safari 15.6.1. Apple recommends all users of these older macOS versions do so.

The same security hole affected iPhone and iPad but it was removed by iOS 15.6.1 and iPadOS 15.6.1, which have been available since Wednesday.

How to update Safari

To update Apple’s Mac web browser, tap on the Apple menu  then choose System Preferences > Software Update. The new Safari version should be there.